Investigating issues placing calls on EWR
Incident Report for 9dash9 Status Page
Resolved
We are investigating reports of call failures on our EWR zone.
Posted Dec 02, 2020 - 01:00 EST